Fehler beim Auflösen: com.google.firebase: firebase-core: 11.2.0

Ich erhalte mehrere “Fehler beim Auflösen” Probleme bei der Synchronisierung meines Projekts. Sie sind alle Firebase und Play-Services im Zusammenhang. Ich habe sichergestellt, dass sie alle gleich sind (11.2.0). Ich habe auch überprüft und die neueste Version für beide ist 11.2.0. Alle anderen Antworten auf ähnliche Fragen beziehen sich auch auf die Aktualisierung der Google Play-Dienste und des Repositorys im SDK-Manager, aber meiner ist bereits auf dem neuesten Stand.

Bildbeschreibung hier eingeben

Bildbeschreibung hier eingeben

Irgendeine Idee, warum ich mein Projekt nicht synchronisieren kann?

EDIT – Aktuelle Arbeitslösung

// Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.3.3' classpath 'com.google.gms:google-services:3.0.0' classpath 'com.google.firebase:firebase-plugins:1.0.4' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } task clean(type: Delete) { delete rootProject.buildDir } 

Fügen Sie maven { url "https://maven.google.com" } zu Ihrer build.gradle Root-Datei hinzu

 allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } 

Play Services und Firebase- Abhängigkeiten sind jetzt über maven.google.com mit der Version 11.2.0 der Google Play-Dienste und Firebase verfügbar.

Sie finden das offizielle Dokument zu Google Play Services hier und das Firebase-Dokument hier. .

 allprojects { repositories { jcenter() maven { url 'https://maven.google.com' } } } 

Wenn Sie das Android-Gradle-Plugin 3.x verwenden, können Sie auch Folgendes verwenden:

 allprojects { repositories { jcenter() google() } } 

Die beste Methode, um dieses Problem zu beheben, ist nicht die manuelle Methode zum Verbinden von Firebase mit Ihrer App.

Ich habe versucht, den neuesten Firebase-Repo hinzuzufügen, indem ich auf diesen Link verweise.

Es zeigte Fehler “konnte die Abhängigkeiten Firebase 11.2.0 nicht auflösen”

FireBase empfiehlt, die Firebase mit Hilfe des FireBase-Assistenten für Android Studio Version 2.2 und höher zu Ihrer App hinzuzufügen. Das manuelle Hinzufügen der neuesten Bibliothek zu Build-Gradle (Modul) führt zu einem Fehler wie oben.

Der Firebase-Assistent hat die unteren Versionen 10.0.1 automatisch in Abhängigkeiten vom Modul “classle-build” eingefügt, das kompatibel ist und aufgetriggers werden könnte.

Die Verwendung des Firebase-Assistenten ist so einfach und in zwei Schritten möglich. Als Referenz können Sie den Abschnitt “Verwenden des Firebase-Assistenten” auf demselben Link wie oben erwähnt verwenden.

Es hat wirklich mit meinem Android Studio 2.3.3 funktioniert. Stellen Sie außerdem sicher, dass Ihr Google Repository auf dem neuesten Stand ist

Ich habe den gleichen Fehler behoben, indem ich die Firebase-Core- Abhängigkeit hinzugefügt habe.

 implementation 'com.google.firebase:firebase-core:16.0.1' 

Mit der Version 16.0.0 von Firebase musste ich

  • 15.0.0 die meisten meiner Google Play Services-Bibliotheken auf 15.0.0 Analytics und TagManager muss 16.0.0
  • setze meine Support-Bibliotheksversionen auf 27.1.1
  • Firebase-core zu 16.0.0

Errichtet gegen SDK 27

Extra Änderungen:

Ich musste meine Analysen auch auf 16.0.0 aktualisieren

  • Implementierung “com.google.android.gms: play-services-analytics: 16.0.0”

Ein Teil der unabhängigen Versionen, die Android kürzlich gemacht hat, rate ich. Möglicherweise müssen Sie versuchen, eine Version der Google Play-Dienste und der Firebase-Bibliotheken hoch- oder herunterzuspielen